Subject: x2goserver 4.0.1.19 mouse position reporting under ubuntu

From: Rick Benkstein <[email-masked]>
Date: Tue, 11 Oct 2016 16:29:19 +0000

Package:  X2goserver
Version: 4.0.1.19

Usage: Using ncurses to report position of mouse - Microsoft x2goclient

Problem:  Works perfectly under Debian7.0 and 7.7 Does not work under Ubuntu 14.04.

Program highlights an area based on the position of the mouse.  It works if the Shift or Ctrl or Alt keys are held else not - If, for instance, the shift key is held the mouse position is reported.

On other Debian systems using Gnome 3.4.2 and Gnome-terminal 3.4.1.1 it works perfectly.  Under Ubuntu 14.04 I have tried Gnome-terminal 3.8.4 and xfce desktop with xfce-terminal

When clicked, the mouse location is reporting the position perfectly - it just doesn't report the movement.

Rick Benkstein
Centurion Data Systems
262-524-9290

---

From: Rick Benkstein <[email-masked]>
Date: Tue, 11 Oct 2016 19:29:21 +0000

I have a solution:

Under curses there is a command mousemask that is used to turn on the mouse.  It has a choice "ALL_MOUSE_EVENTS" and another "REPORT_MOUSE_POSITION".  Under the Debian system the first choice does both.  Under Ubuntu when I chose both (ALL_MOUSE_EVENTS | REPORT_MOUSE_POSTION) the mouse position was captured.

Rick Benkstein

-----Original Message-----
From: X2Go Bug Tracking System [mailto:[email-masked]] 
Sent: Tuesday, October 11, 2016 11:40 AM
To: Rick Benkstein <[email-masked]>
Subject: Bug#1101: Acknowledgement (x2goserver 4.0.1.19 mouse position reporting under ubuntu)

Thank you for filing a new Bug report with X2Go.

This is an automatically generated reply to let you know your message has been received.

Your message is being forwarded to the package maintainers and other interested parties for their attention; they will reply in due course.

Your message has been sent to the package maintainer(s):
 X2Go Developers <[email-masked]>

If you wish to submit further information on this problem, please send it to [email-masked].

Please do not send mail to [email-masked] unless you wish to report a problem with the Bug-tracking system.

--
1101: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1101
X2Go Bug Tracking System
Contact [email-masked] with problems