Subject: Bug#1072: X2Go Client: top 24 pixels in fullscreen session do not respond to mouse clicks

From: Chris Martin <[email-masked]>
Date: Fri, 12 Aug 2016 20:27:00 -0700

Package: x2goclient
Version: 4.0.5.1

I am trying to start a full screen X2Go session which 1. takes up the
entire display, and 2. responds to my mouse clicks everywhere in the
session, but cannot accomplish this with any combination of settings.

Client OS: Debian Jessie / 8 / Stable, GNOME 3 desktop environment
Client X2Go Client: 4.0.5.1 and 4.0.3.1
Server OS: Xubuntu 16.04 LTS
Server x2goserver version: 4.0.1.19
Server x2goserver-xsession version: 4.0.1.19

When I choose "fullscreen", I get different behavior intermittently:

1. The client spawns across the entire screen but the *top panel inside
the X2Go session* does not respond to any mouse clicks. I suspect the
panel in my GNOME session running the X2Go client (which occupies the
same pixels behind the panel inside the X2Go session) is stealing mouse
focus. My mouse pointer turns black instead of white when I hover over
the top 24 pixels or so, inside the X2Go session.

2. The client spawns what I would call a "maximized window". The top of
the screen is still consumed by the title bar of the X2Go window, and
the panel of the enclosing GNOME session in which the X2Go client is
running.

I have observed both cases 1 (most common) and 2 with X2Go Client
4.0.5.1, and only case 1 with X2Go client 4.0.3.1.

When I choose "Display 1" in the Input/Output settings, the X2Go session
displays only in the upper-left quadrant of my display; the rest of the
screen is black.

Thank you,

Chris Martin

---

From: Ulrich Sibiller <[email-masked]>
Date: Fri, 26 Aug 2016 10:22:45 +0200

> the panel of the enclosing GNOME session in which the X2Go client is

Does pressing CTRL-ALT-F within the session help?

> displays only in the upper-left quadrant of my display; the rest of the

Uli

---

From: Sylvain Cuaz <[email-masked]>
Date: Tue, 9 Feb 2021 15:02:10 +0100

Hi,

This is still a problem on Ubuntu 20.04 with X2Go Client 4.1.2.2 connecting to XFCE through 
x2goserver 4.1.0.4-0~1914~ubuntu16.04.1

If I put both my local gnome panel and the remote XFCE panel at the top, then the top pixels in 
remote desktop cannot be clicked (tool tips work).

If I put my local gnome panel to the left, then only the top left corner pixels of the remote top 
panel have the problem (which is where they intersect).

If I switch my local desktop environment to XFCE, no matter where I put the panels, it always work.

Cheers.

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 9 Feb 2021 17:03:35 +0100

can you please post a screenshot of that situation where it does not
work? I don't really get what you mean by "If I put both my local
gnome panel and the remote XFCE panel at the top".

Uli

On Tue, Feb 9, 2021 at 3:05 PM Sylvain Cuaz <[email-masked]> wrote:
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

---

From: Sylvain Cuaz <[email-masked]>
Date: Tue, 9 Feb 2021 17:31:39 +0100

> gnome panel and the remote XFCE panel at the top".

I mean on my local session (where I launch x2go client), I have a gnome panel at the top of my 
screen (the default)

https://simple.wikipedia.org/wiki/Ubuntu#/media/File:Ubuntu_20.10_Groovy_Gorilla_Desktop.png

Then I launch x2go client and switch to full screen.

https://i.stack.imgur.com/jaK2z.png

The top pixels in the remote session inside x2go cannot be interacted with. Presumably because even 
though I can't see any pixels of my local gnome session, the clicks inside x2go aren't grabbed by 
x2go but rather by my local session. I.e. I cannot click on the application menu nor switch windows 
using the top panel. This a full screen bug, in windowed mode, the remote XFCE panel can be clicked.

If on the other hand there's no gnome panel underneath the full screen x2go (e.g. my local gnome 
panel is on my right screen, my remote XFCE panel is on the left screen) then I can interact fine.

Or I as said if my local desktop environment is XFCE then it always work no matter where are any panels.

HTH

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 9 Feb 2021 17:50:59 +0100

How are you switching to fullscreen? In the default keyboard configuration
there's ctrl+alt+f and ctrl+alt+Shift+f. Can you please check if that
problem show with both. Also note the nxagent 3.5-99.25 is buggy regarding
full screen, so maybe you should try updating tie the freshly released
3.5.99.26.

Uli

Sylvain Cuaz <[email-masked]> schrieb am Di., 9. Feb. 2021,

---

From: MK <[email-masked]>
Date: Thu, 04 May 2023 02:36:22 +0200

Hallo, Schatz,

Es tut mir leid, Sie zu stören, aber ich bin Single, einsam und brauche 
einen fürsorglichen, liebevollen und romantischen Begleiter.

Ich bin ein heimlicher Verehrer und würde gerne die Gelegenheit nutzen, 
mehr voneinander zu erfahren.

Hoffentlich wird es der Beginn einer langfristigen Kommunikation 
zwischen uns sein.

Bitte lassen Sie mich wissen, was Sie denken, senden Sie einfach eine 
Antwort auf meine Nachricht, ich freue mich, von Ihnen zu hören.

Umarmungen und Küsse,

Heimlicher Verehrer,

MK.