Subject: Cluster SSH (cssh) has keyboard issues with non-US keyboards when called via X2GoClient

From: Stefan Baur <[email-masked]>
Date: Mon, 8 Aug 2016 18:51:57 +0200

package: x2goclient
version: 4.0.5.1

When cssh is started as a remote application, certain keys aren't
forwarded properly when a non-US keyboard setting is present on the client.

This happens both with Windows and Linux X2Go clients.

It does *not* happen when cssh is executed directly on the client, nor,
if it is executed using ssh -X.

It also does *not* happen when the "problematic" keys are entered
manually in a single SSH client window *belonging to cssh* - it happens
only if they are entered in the *central* cssh window, from which they
are supposed to be cloned to all SSH client windows.

On a Swiss German keyboard, "^", "~", "´" and "`" are known to cause
problems.
On a German keyboard, "~" works fine, while "^", "´" and "`" remain an
issue.

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 8 Aug 2016 20:20:06 +0200

Can you please toggle client side deadkey settings and check if the problem persists? On Windows switch to swiss (edv).

Vom Smartphone gesendet.

----- Ursprüngliche Nachricht -----
Von: "Stefan Baur" <[email-masked]>
Gesendet: ‎08.‎08.‎2016 19:01
An: "[email-masked]" <[email-masked]>
Betreff: [X2Go-Dev] Bug#1069: Cluster SSH (cssh) has keyboard issues withnon-US keyboards when called via X2GoClient

package: x2goclient
version: 4.0.5.1

Kind Regards,
Stefan Baur

---

From: Stefan Baur <[email-masked]>
Date: Tue, 9 Aug 2016 17:01:53 +0200

Am 08.08.2016 um 20:20 schrieb Ulrich Sibiller:
> On Windows switch to swiss (edv).

There is no such option on Windows 7 ...
I can set it to:
- "Deutsch (Deutschland)" with sub-options
  - "Deutsch" and
  - "Deutsch (IBM)"
- "Deutsch (Schweiz)" with sub-options
  - "Deutsch (Schweiz)" and
  - "Deutsch (IBM)"
     note that this is the same as above for Deutschland,
     there is NO "Deutsch (Schweiz) (IBM)"

Kind Regards,
Stefan Baur

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 9 Aug 2016 17:31:51 +0200

>      there is NO "Deutsch (Schweiz) (IBM)"

Yeah, I had no Windows at hand to look up the exact name. So I'd
suggest to retry using "Deutsch (Schweiz)/Deutsch(IBM)" (IBM is the
one I meant).

Uli

---

From: Stefan Baur <[email-masked]>
Date: Wed, 10 Aug 2016 16:27:26 +0200

> suggest to retry using "Deutsch (Schweiz)/Deutsch(IBM)" (IBM is the

Test situation:

Windows 7, Standard German Keyboard (no Swiss, no IBM)

x2goclient keyboard settings "autodetect keyboard":
^ -> nothing
^^ -> h~
~ -> ~
` -> nothing
`` -> h~
´ -> nothing
´´ -> h~

So only "~" works as expected.

Now here's the funny part:
Once you click into a single SSH window belonging to CSSH, and type "^^"
there, it will become a "^" ...
and EVERY subsequent typing of "^^", "``", or "´´" will become an "^".

If you do it with "``" instead, every subsequent typing of any of those
three characters becomes an "`", and so on.

x2goclient keyboard settings "pc105 de nodeadkeys":
Works fine for every single one of those characters, just like with the
US keyboard.

Changing the keyboard to "Deutsch (IBM)" did not change a thing.
"Deutsch (IBM)" is not the same as "de-latin1-deadkeys" on Linux, though
- it merely disables shifting of the number row when capslock is pressed
(at least that is my understanding).

Kind Regards,
Stefan Baur

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 10 Aug 2016 23:01:53 +0200

> So only "~" works as expected.

What about ^<space> instead of ^^?

> Works fine for every single one of those characters, just like with the

So if you remove the nodeadkeys, does it work then?

> (at least that is my understanding).

Yes, you are probably right, sorry for the confusion.

Uli

---

From: Stefan Baur <[email-masked]>
Date: Thu, 11 Aug 2016 00:23:59 +0200

> What about ^<space> instead of ^^?

^<space> gives the same result as ^^.

> So if you remove the nodeadkeys, does it work then?

No. It works if I *add* "nodeadkeys" to "pc105 de".
"autodetect" and "pc105 de" are the same setting, at least on my client.

Kind Regards,
Stefan