Subject: Bug#1064: Unhandled exception on Windows after remote connection lost

From: "Chavez, Christopher A. (Assoc)" <[email-masked]>
Date: Tue, 26 Jul 2016 18:23:45 +0000

Package: x2goclient
Version: 4.0.5.1

Using Windows 7 Enterprise 64bit. This issue occurs after the connection was somehow lost (possibly due to an ssh-related setting on the server, but this issue can still be triggered by disconnecting the network connection and waiting 120 seconds).

Message dialog that appears:
"The connection with the remote server was shut down. Please check the state of your network connection."

When that message appears, the main X2Go Client window is no longer responsive.
Last few messages in session log that appear for this issue:

Warning: No data received from remote proxy within 30 seconds.
x2go-WARNING-1> "English language requested, not loading translator."
x2go-WARNING-1> "English language requested, not loading translator."
Error: No data received from remote proxy within 120 seconds.
Session: Terminating session at '...'

Windows then brings up a message:
"x2goclient.exe has stopped working.
A problem caused the program to stop working correctly. Please close the program."
(options: Close the program, Debug the program)

Visual Studio Debugger says:

Unhandled exception at 0x61AE3784 (libssh.dll) in x2goclient.exe: 0xC0000005: Access violation reading location 0x00000010.

I installed X2Go Client using the installer rather than compiling it, so I don't have any further debugging info.

Christopher A. Chavez
National Institute of Standards and Technology

---

From: Stefan Baur <[email-masked]>
Date: Tue, 9 Aug 2016 09:56:26 +0200

Am 26.07.2016 um 20:23 schrieb Chavez, Christopher A. (Assoc):

> Using Windows 7 Enterprise 64bit. This issue occurs after the connection
> was somehow lost (possibly due to an ssh-related setting on the server,
> but this issue can still be triggered by disconnecting the network
> connection and waiting 120 seconds).

[...]

> (options: Close the program, Debug the program)

We've seen this before, with certain Nvidia drivers.
See http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=967
Could it be that you're using a Nvidia card, too?

> I installed X2Go Client using the installer rather than compiling it, so
> I don’t have any further debugging info.

Recent Windows builds of X2GoClient allow you to select a custom install
that drops an x2goclient.debug.exe next to the regular one.
If you're willing to assist, try running that and see if it generates
more verbose output.

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Christopher Chavez <[email-masked]>
Date: Tue, 9 Aug 2016 14:41:52 -0500

> Could it be that you're using a Nvidia card, too?

I can confirm that an Nvidia card was used on the machine. I don't remember the
specific model, but it was likely a circa-2014 workstation series, my best guess
is Quadro K620.

> If you're willing to assist, try running that and see if it generates

I recently completed the appointment at my last employer, so I no longer have
access to that machine (and am following up using personal email).
At the moment, I don't have a comparable system that I can try reproducing the
issue on, but I'll keep your suggestion in mind for any debugging with the
installer build.

Christopher Chavez

---

From: Farhan Far <[email-masked]>
Date: Mon, 29 Apr 2024 16:22:29 +0200

I tried to get in touch with you on the phone. However, your line was busy.