Subject: pyhoca-gui can't be installed on OpenSUSE from project repository, OBS repository version throws errors

From: "Albrecht Kolthoff" <[email-masked]>
Date: Sun, 10 Jul 2016 15:12:19 +0200

Package: pyhoca-gui
Version: 0.5.0.6-0.0

While the x2goserver and x2goclient packages are running fine on my machines (server: OpenSUSE Leap 42.1, client: OpenSUSE 13.2), the pyhoca-gui package can't be installed from the x2go repository:
http://packages.x2go.org/opensuse/13.2/main/x86_64/

The same applies to the version in the heuler repository which contains nightly builds, as far as I understand. In both cases the package carries a dependency on python-wxWidgets-2_9 which can't be fulfilled by the OpenSUSE repositories; these offer only the 3_0 and alternatively the 2_8 packages.

The OpenSUSE Build service version (which is some minor versions behind the current ones on the x2go project server) actually has a 3_0 dependency (instead of 2_9) and can be installed:
http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/openSUSE_13.2/

But: this version refuses to run. When started from a terminal command line, it throws these errors:

ak@tantalus:~> pyhoca-gui
Traceback (most recent call last):
   File "/usr/bin/pyhoca-gui", line 35, in <module>
     from pyhoca.wxgui.launcher import PyHocaGUI_Launcher
   File "/usr/lib/python2.7/site-packages/pyhoca/wxgui/launcher.py", line 38, in <module>
     from x2go import X2GOCLIENT_OS
   File "/usr/lib/python2.7/site-packages/x2go/__init__.py", line 189, in <module>
     from defaults import X2GOCLIENT_OS
   File "/usr/lib/python2.7/site-packages/x2go/defaults.py", line 388, in <module>
     RSAHostKey = paramiko.RSAKey.generate(RSAKEY_STRENGTH)
   File "/usr/lib/python2.7/site-packages/paramiko/rsakey.py", line 156, in generate
     public_exponent=65537, key_size=bits, backend=default_backend()
   File "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 35, in default_backend
     _default_backend = MultiBackend(_available_backends())
   File "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 22, in _available_backends
     "cryptography.backends"
AttributeError: 'EntryPoint' object has no attribute 'resolve'

Which leads to the situation, that pyhoca-gui can't be run on OpenSUSE at the moment. Which I regret.

Best regards
Albrecht Kolthoff

--

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 14 Jul 2016 10:42:26 +0000

Control: tags -1 not-a-bug

On  So 10 Jul 2016 15:12:19 CEST, Albrecht Kolthoff wrote:

> Package: pyhoca-gui
> Version: 0.5.0.6-0.0
>
>
> While the x2goserver and x2goclient packages are running fine on my  
> machines (server: OpenSUSE Leap 42.1, client: OpenSUSE 13.2), the  
> pyhoca-gui package can't be installed from the x2go repository:
> The same applies to the version in the heuler repository which  
> contains nightly builds, as far as I understand. In both cases the  
> package carries a dependency on python-wxWidgets-2_9 which can't be  
> fulfilled by the OpenSUSE repositories; these offer only the 3_0 and  
> alternatively the 2_8 packages.
>
> The OpenSUSE Build service version (which is some minor versions  
> behind the current ones on the x2go project server) actually has a  
> 3_0 dependency (instead of 2_9) and can be installed:
>   File  
> "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 35, in  
> default_backend
>   File  
> "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 22, in  
> _available_backends
>     "cryptography.backends"

This seems to be an issue buried in Python Paramiko and they way it is  
packaged for openSUSE. PyHoca-GUI relies on a working Paramiko Python  
module. What it does above is

   paramiko.RSAKey.generate(RSAKEY_STRENGTH)

And this call somehow fails. Please get this fixed for your distro and  
then pyhoca-gui will (hopefully) work.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: "Albrecht Kolthoff" <[email-masked]>
Date: Mon, 18 Jul 2016 20:23:48 +0200

Today a package update from an openSUSE repository has been installed here as python-paramiko-2.0.0-45.1 and now pyhoca-gui is running without these error messages and apparently fully functional.

Problem solved, case closed. Thank you for your time and explanation.

--

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 21 Jul 2016 14:43:37 +0000

Control: close -1

On  Mo 18 Jul 2016 20:23:48 CEST, Albrecht Kolthoff wrote:

> Today a package update from an openSUSE repository has been  
> installed here as python-paramiko-2.0.0-45.1 and now pyhoca-gui is  
> running without these error messages and apparently fully functional.
>

Thanks for letting us know about this issue being solved for you.  
Closing the bug.

Mike
-- 

DAS-NETZWERKTEAM