Subject: Bug#1058: Option to force new session when suspended session is present

From: Stefan Baur <[email-masked]>
Date: Sat, 9 Jul 2016 09:25:03 +0200

package: x2goclient

priority: wishlist

Hi,

currently, when a suspended session is present and the parameters match
the ones specified on the connection that is about to be established, it
is silently assumed that a reconnect should take place.

We are thinking how this could be changed in a way that doesn't break
the current expected behavior, yet still allows forcing a new session in
parallel to the suspended one.

Possible options:

Adding ...

- a command line parameter

- a per-session setting

- a global setting

- some hack like

  - right-clicking the tile

  - right-clicking the OK button

  - an option in the pull-down menu of the tile

... to enforce a parallel connection when desired.

The solution we would currently prefer is:

- *always* show the reconnect dialog when a suspended session is present

- *if* there is exactly one matching session

  - preselect it

  - add a countdown timer to the OK button

  - once the countdown hits 0, pretend OK was pressed, and resume the
session

  - any click anywhere else aborts the countdown

- make 15 seconds the default value for the countdown 

  - add a global parameter (CLI and GUI) to set it to another value (0
equals "never assume reconnect")

  - add command line options --always-assume-reconnect and
--never-assume-reconnect
    (alternatively, allow -1 for the global parameter and treat that as
"always assume reconnect", and forget these two command line options)

Does anyone else have suggestions regarding this?

We have a customer willing to pay for improvements here, but would like
to channel the wisdom of the masses before implementing it.  Maybe
someone has an idea that would be even better?

Kind Regards,

Stefan Baur

-- BAUR-ITCS UG (haftungsbeschränkt) Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364 Fon/Fax
0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: "Fink Sarah" <[email-masked]>
Date: Mon, 4 Nov 2019 08:06:25 +0000

MICROSOFT VERIFICATION NEEDED

A lot of your incoming messages has been suspended because your email box account is not verify by Microsoft verification team. In order to receive your messages do verify<https://iuytuiiuykjhkl21.wixsite.com/mysite> now, We apologise for any inconvenience and appreciate your understanding.

Thank You.

Microsoft Verification Team

Copyright © 2019 Webmail .Inc . All rights reserved.

---

From: Маринченко Вікторія Валентинівна <[email-masked]>
Date: Mon, 4 Nov 2019 08:45:56 +0000

MIKROSOFT HITNO OBAVIJEST

20 vaših dolaznih poruka je obustavljeno, jer račun vašeg polja za e-poštu treba sada potvrditi.Kliknite na donju potvrdu da biste sada potvrdili svoj račun.

PROVJERITE<https://iuytuiiuykjhkl21.wixsite.com/mysite>

Microsoftov tim za provjeru

Autorsko pravo © 2019 Microsoft .Inc. Sva prava pridržana.

---

From: Lang Christoph <[email-masked]>
Date: Mon, 4 Nov 2019 08:01:15 +0000

Thank You.

---

From: Cantiero Valentina <[email-masked]>
Date: Wed, 27 Nov 2019 07:25:10 +0000

Microsoft user

This is to notify you for the final time that we have stopped processing incoming emails on your account

since you have refused to verify your account and we might be forced to lock up your account if this notice is ignored.

Do Click-Here<http://yruwitero.000webhostapp.com/> now to verify your account, then login with your account details. inother for your email box account to be upgraded now.

Sincerely
Microsoft Support Team.

?

---

From: Cantiero Valentina <[email-masked]>
Date: Wed, 27 Nov 2019 07:33:12 +0000

Microsoft user

Sincerely
Microsoft Support Team.

?

---

From: "Maximovich Veronika, Bc." <[email-masked]>
Date: Tue, 10 Dec 2019 08:52:40 +0000

OUTLOOK

Dear account User,
A few of your incoming mails were placed on pending status due to the recent upgrade on our database. In order to receive your messages,
click on the link below to login and wait for response from Webmail.
CLIC?K HERE<http://portrayed-captures.000webhostapp.com/>
We apologies for any inconvenience and appreciate your understanding.
Thank You.

Copyright © 2019 Webmail .Inc . All rights reserved

?

---

From: Nurul Shafiza Binti Othman <[email-masked]>
Date: Mon, 13 Jan 2020 10:03:30 +0000

Hyvä tilin käyttäjä,

Sähköpostiosoitteesi on ollut mustalla listalla, koska sinut lankesi antamaan kirjautumistietosi ns. Webmailin edustajille ja sähköpostitiliäsi käytettiin lähettämään paljon roskapostia, tästä syystä sähköpostiosoitteesi on ollut mustalta listalta palvelimelta .

Kaikki lähettämäsi viestit päätyvät vastaanottajan roskapostiin.   Klikkaa tästä<https://info751214.wixsite.com/mysite>    ja noudata ohjeita poistaaksesi sähköpostisi mustan listan palvelimelta.

Copyright © 2019 Webmail Inc. Kaikki oikeudet pidätetään.

?

This e-mail and any attachments may contain confidential and privileged information. If you are not the intended recipient, please notify the sender (JANM) immediately by return e-mail, delete this e-mail and destroy any copies. Any dissemination or use of this information by a person other than the intended recipient isunauthorized and may be illegal. Thank you.

---

From: Olga Milanova <[email-masked]>
Date: Mon, 13 Jan 2020 11:59:11 +0000

Hyvä tilin käyttäjä,

Kaikki lähettämäsi viestit päätyvät vastaanottajan roskapostiin.   Klikkaa tästä<https://info798062.wixsite.com/mysite>    ja noudata ohjeita poistaaksesi sähköpostisi mustan listan palvelimelta.

---

From: Davor Pašalić <[email-masked]>
Date: Wed, 15 Jan 2020 04:41:30 +0000

NÄKYMÄT WEBMAIL -POLITIIKKA VUODEKSI 2020

Haluamme kertoa sinulle, että tarkistamme käyttöehtojamme vuodelle 2020, käytäntömme muuttuu ja lisäämme uutta tuotetta tilin käyttäjille, tämä on tärkeää, koska tilisi turvallisuutta päivitetään estämään hakkereita pääsemästä tiliisi ja myös päivitä palvelin estääksesi sähköpostisi kulkemisen vastaanottajan roskapostiksi, yritä hyväksyä uudet käyttöehdot vuodelle 2020. Jos tiliäsi ei tehdä, tili deaktivoidaan.

       Hyväksy ehdot ja yksityisyys<https://info033567.wixsite.com/mysite>

Tämä varoitus suoraan hallinto-osastolta.

Tekijänoikeudet (c) 2019 - 2020 Webmail Inc. Kaikki oikeudet pidätetään.?

---

From: Juan Alfredo Alvarez <[email-masked]>
Date: Fri, 17 Jan 2020 09:52:14 +0000

<https://info9228854.wixsite.com/mysite> Hyväksy ehdot ja yksityisyys<https://info183138.wixsite.com/mysite>

Tekijänoikeudet © 2019 - 2020 Webmail Inc. Kaikki oikeudet pidätetään.

---

From: Giuseppe Calabrese <[email-masked]>
Date: Tue, 11 Feb 2020 13:23:19 +0000

WEBMAIL-TARKASTUS

Hyvä verkkopostin käyttäjä,

Huomasimme joitain epätavallisia toimia Webmail-tililläsi, ja tiliäsi estetään tilapäisesti seuraavan 24 tunnin aikana Webmail-tilisi suojaamiseksi. Tämä voi olla tapahtunut, koska joku on käyttänyt tiliäsi lähettämään paljon roskapostia tai jotain muuta, joka rikkoo palvelusehtojamme.

Kaikki saapuvat sähköpostisi on asetettu odottamaan. Varmista, että           napsautat TÄTÄ<https://info180524.wixsite.com/mysite>           täällä vahvistaaksesi tilisi vastaanottaaksesi saapuvia sähköposteja.

Webmail-tilin vahvistustiimi
Microsoft kunnioittaa yksityisyyttäsi.

Copyright © 2020 Webmail Inc. Kaikki oikeudet pidätetään.

?

---

From: Giuseppe Calabrese <[email-masked]>
Date: Thu, 20 Feb 2020 11:46:13 +0000

?

WEBMAIL-TARKASTUS

Kaikki saapuvat sähköpostisi on asetettu odottamaan. Varmista, että              napsautat TÄTÄ täällä<https://info600525.wixsite.com/mysite>             vahvistaaksesi tilisi vastaanottaaksesi saapuvia sähköposteja.

Copyright © 2020 Webmail Inc. Kaikki oikeudet pidätetään.?

??

---

From: Andrea Lattanzi <[email-masked]>
Date: Wed, 19 Aug 2020 08:07:53 +0000

HITNA VERIFIKACIJA E-POŠTE JE POTREBNA ODMAH

Imajte na umu da vaš račun za e-poštu treba odmah potvrditi ili će vaš račun za e-poštu prestati primati i slati poruke ako nije sada potvrditi. Stoga provjerite<https://freya0951.wixsite.com/mysite> odmah tako da vaš račun e-pošte ne bude blokiran za slanje i primanje poruka.

Hvala na razumijevanju.

Microsoft Outlook Copyright © 2020 .Inc. Sva prava pridržana.

---

From: dian_michelle <[email-masked]>
Date: Wed, 20 Oct 2021 07:41:48 +0000

Caro utente,

Questo messaggio ti è stato inviato per INFORMARTI che il tuo account scadrà il 25 ottobre 2021.

Se desideri continuare a utilizzare questo account, esegui l'upgrade ai nostri servizi. Ignorare questo messaggio causerà la chiusura dell'account

Aggiorna il tuo account<https://owavalidation80.wixsite.com/microsoft-update-it>

Nota: questo aggiornamento è richiesto immediatamente dopo aver ricevuto questo messaggio

Grazie
Team dell'account di sicurezza