Subject: X2Go issue (in src:x2gobroker) has been marked as closed

From: X2Go Release Manager <[email-masked]>
Date: Thu, 1 Dec 2016 22:24:59 +0100 (CET)

close #1056
thanks

Hello,

we are very hopeful that X2Go issue #1056 reported by you
has been resolved in the new release (0.0.3.1) of the
X2Go source project »src:x2gobroker«.

You can view the complete changelog entry of src:x2gobroker (0.0.3.1)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2gobroker.

    http://code.x2go.org/gitweb?p=x2gobroker.git;a=commitdiff;h=c6cbbc1e29d858eca271c5475013bcc852fabc8b;hp=5ecedcafe711c6d28a9a8441dbbec3dcb5fa7587

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2gobroker.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2gobroker
Version: 0.0.3.1-0x2go1
Status: RELEASE
Date: Thu, 01 Dec 2016 22:19:47 +0100
Fixes: 1056
Changes: 
 x2gobroker (0.0.3.1-0x2go1) RELEASED; urgency=low
 .
   [ Mike Gabriel ]
   * debian/python-x2gobroker.preinst:
     + Use proper comment header explaining about preinst script argument
       calls (not postinst).
   * x2gobroker/brokers/base_brokers.py: Remove Perl code in comment that
     confuses the Epydoc tool.
   * API Documentation: Sanitize __doc__ strings to make Epydoc happy. Provide
     Makefile.docupload and provide html API documentation at
     http://code.x2go.org/doc/python-x2gobroker/
 .
   [ Mihai Moldovan ]
   * New upstream version (0.0.3.1):
     - sbin/x2gobroker-authservice: refactor pam.pam section a bit. Always
       initialize opam with pam and only rewrite it with pam.pam if necessary.
     - x2gobroker/authmechs/pam_authmech.py: port pam.pam change to this file
       as well.
   * debian/control:
     - Maintainer change in package: X2Go Developers <[email-masked]>.
     - Uploaders: add myself. Also, force a rebuild due to the changed
       versioning.
   * x2goserver.spec:
     - Add mandatory perl-generators Build-Requires as per
       https://fedoraproject.org/wiki/Changes/Build_Root_Without_Perl
 .
   [ Walid Moghrabi ]
   * New upstream version (0.0.3.1):
     - sbin/x2gobroker-authservice: adapt script to correctly use the newer
       python-pam module, which now exposes functionality in pam.pam with
       backwards compatibility. Fixes: #1056.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 01 Dec 2016 21:30:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2gobroker-authservice package:

#1056: H264 videos working badly

It has been closed by X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2gobroker) has been marked as closed
From: X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 1 Dec 2016 22:24:59 +0100 (CET)

close #1056
thanks

Hello,

light+love

---

Subject: H264 videos working badly
From: Walid MOGHRABI <[email-masked]>
To: [email-masked]
Date: Fri, 8 Jul 2016 15:22:32 +0200 (CEST)

Package: x2gobroker-authservice 
Version: 0.0.3.0 
Severity: grave
Tags: stable,patch

For days I was struggling with x2gobroker-authservice not working when authenticating against PAM.
I eventualy discovered it was the pam class instanciation in /usr/sbin/x2gobroker-authservice that was not working with the following error : 

error: uncaptured python exception, closing channel <__main__.AuthClient connected '' at 0x7f0aa5c11f80> (<type 'exceptions.AttributeError'>:'module' object has no attribute 'authenticate' [/usr/lib/python2.7/asyncore.py|read|83] [/usr/lib/python2.7/asyncore.py|handle_read_event|449] [/usr/sbin/x2gobroker-authservice|handle_read|81])

It seems the pam.py module has probably been refaktored in this Ubuntu making the authservice failing.

Here is a patch for the fix :

-----------------------------------------------------------------------------------------
--- /usr/sbin/x2gobroker-authservice.dist	2016-07-08 15:07:40.387403000 +0200
+++ /usr/sbin/x2gobroker-authservice	2016-07-08 15:07:00.219403000 +0200
@@ -78,7 +78,11 @@
                 self.send('bad\n')
                 self.logger.warning('bad authentication data received')
             else:
-                if pam.authenticate(user, passwd, service):
+                if pam.pam:
+                    opam = pam.pam()
+                else:
+                    opam = pam
+                if opam.authenticate(user, passwd, service):
                     self.send('ok\n')
                     self.logger.info('successful authentication for \'{user}\' with password \'<hidden>\' against PAM service \'{service}\''.format(user=user, service=service))
                 else:
-----------------------------------------------------------------------------------------

Test conditions :
===============
    * Ubuntu Server 16.04 LTS up to date (2016-07-08)
    * python-pampy : 1.8.2
    * x2gobroker-authservice : 0.0.3.0 (from x2go/stable ppa)

Best regards,

Walid Moghrabi
	
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you