Subject: Bug#1051: Info received and FILED only (Closing because sunweaver said so)

From: "X2Go Bug Tracking System" <[email-masked]>
Date: Mon, 15 Jan 2024 21:10:03 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #1051.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1051: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1051
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 15 Jan 2024 21:10:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the buildscripts package:

#1051: failing .deb builds due to flaw in code-to-version conversion scripts

It has been closed by Stefan Baur <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Stefan Baur <[email-masked]> by
replying to this email.

Subject: Closing because sunweaver said so
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Mon, 15 Jan 2024 22:08:05 +0100

Control: close -1
Control: archive -1

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

Subject: failing .deb builds due to flaw in code-to-version conversion scripts
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Mon, 04 Jul 2016 12:40:16 +0000

Package: buildscripts
Severity: important

Hi Mihai,

I have played with X2Go Server a little today, trying to get the new  
execution logic for nxagent/x2goagent into X2Go Server 4.1.0.0. While  
doing that, I stumbled over build failures due to a flaw in the  
buildscripts.

This fixes the occurring issues:

```
jenkins@japsand:~/buildscripts$ git diff
diff --git a/bin/debian-codename-to-version.sh  
b/bin/debian-codename-to-version.sh
index 8bd0384..315fcbd 100755
--- a/bin/debian-codename-to-version.sh
+++ b/bin/debian-codename-to-version.sh
@@ -76,7 +76,5 @@ case "${codename}" in
         ("rex") echo "1.2";;
         ("buzz") echo "1.1";;

-       (*) ret="1";;
+       (*) echo "1";;
  esac
-
-return "${ret}"
diff --git a/bin/ubuntu-codename-to-version.sh  
b/bin/ubuntu-codename-to-version.sh
index 943e130..f0c1418 100755
--- a/bin/ubuntu-codename-to-version.sh
+++ b/bin/ubuntu-codename-to-version.sh
@@ -66,7 +66,5 @@ case "${codename}" in
         ("hoary") echo "5.04";;
         ("warty") echo "4.10";;

-       (*) ret="1";;
+       (*) echo "1";;
  esac
-
-return "${ret}"
```

light+love
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de