Subject: Bug#1051: failing .deb builds due to flaw in code-to-version conversion scripts

From: Mike Gabriel <[email-masked]>
Date: Mon, 04 Jul 2016 12:40:16 +0000

Package: buildscripts
Severity: important

Hi Mihai,

I have played with X2Go Server a little today, trying to get the new  
execution logic for nxagent/x2goagent into X2Go Server 4.1.0.0. While  
doing that, I stumbled over build failures due to a flaw in the  
buildscripts.

This fixes the occurring issues:

```
jenkins@japsand:~/buildscripts$ git diff
diff --git a/bin/debian-codename-to-version.sh  
b/bin/debian-codename-to-version.sh
index 8bd0384..315fcbd 100755
--- a/bin/debian-codename-to-version.sh
+++ b/bin/debian-codename-to-version.sh
@@ -76,7 +76,5 @@ case "${codename}" in
         ("rex") echo "1.2";;
         ("buzz") echo "1.1";;

-       (*) ret="1";;
+       (*) echo "1";;
  esac
-
-return "${ret}"
diff --git a/bin/ubuntu-codename-to-version.sh  
b/bin/ubuntu-codename-to-version.sh
index 943e130..f0c1418 100755
--- a/bin/ubuntu-codename-to-version.sh
+++ b/bin/ubuntu-codename-to-version.sh
@@ -66,7 +66,5 @@ case "${codename}" in
         ("hoary") echo "5.04";;
         ("warty") echo "4.10";;

-       (*) ret="1";;
+       (*) echo "1";;
  esac
-
-return "${ret}"
```

light+love
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: Mihai Moldovan <[email-masked]>
Date: Mon, 4 Jul 2016 22:18:40 +0200

> @@ -66,7 +66,5 @@ case "${codename}" in

NAK, that would go against the script's contract as detailed in the comments.
There shouldn't be any output in case the code name provided is invalid, the
status is supposed to be reflected by the return value. There were a few
problems I fixed, though.

How about

http://code.x2go.org/gitweb?p=buildscripts.git;a=commitdiff;h=3153ec59c323cdc2efb3d394f0e4e2f98ca28c93

and

http://code.x2go.org/gitweb?p=buildscripts.git;a=commitdiff;h=8bb92fd510b40fe80759460fb96c1fafa1423fba

instead?

Mihai