X2Go Bug report logs - #1043
Atom editor finished immediately after starting.

version graph

Package: nx-libs; Maintainer for nx-libs is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: SHIINA Hideaki <shiina@yndrd.com>

Date: Mon, 13 Jun 2016 03:30:01 UTC

Severity: normal

Found in version 3.5.0.32

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1043; Package atom. (Mon, 13 Jun 2016 03:30:01 GMT) (full text, mbox, link).


Acknowledgement sent to SHIINA Hideaki <shiina@yndrd.com>:
New Bug report received and forwarded. Copy sent to owner@bugs.x2go.org. (Mon, 13 Jun 2016 03:30:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: SHIINA Hideaki <shiina@yndrd.com>
To: submit@bugs.x2go.org
Subject: Atom editor finished immediately after starting.
Date: Mon, 13 Jun 2016 12:18:56 +0900
package: atom

X2Go vesions
x2goagent: 3.5.0.32
x2goserver: 4.0.1.19
x2goserver-extensions: 4.0.1.19
x2goserver-xsession: 4.0.1.19

atom versions
Atom : 1.8.0
Electron: 0.36.8
Chrome : 47.0.2526.110
Node : 5.1.1

situations:
I use X2Go server on Ubuntu 14.04.
I started atom editor on X2Go environment.
Then, It immediately finished with a message below.
 "App load time: 147ms"
 
This problem is known to users and discussed at atom user forum.
https://discuss.atom.io/t/impossible-launch-on-ubuntu-through-x2go-client/26568

But, There is no solution about it.
So, I wonder if it's a bug of X2Go.


thanks.


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1043; Package atom. (Thu, 23 Jun 2016 20:00:02 GMT) (full text, mbox, link).


Acknowledgement sent to Ulrich Sibiller <uli42@gmx.de>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Thu, 23 Jun 2016 20:00:02 GMT) (full text, mbox, link).


Message #10 received at 1043@bugs.x2go.org (full text, mbox, reply):

From: Ulrich Sibiller <uli42@gmx.de>
To: SHIINA Hideaki <shiina@yndrd.com>, 1043@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1043: Atom editor finished immediately after starting.
Date: Thu, 23 Jun 2016 21:57:48 +0200
On Mon, Jun 13, 2016 at 5:18 AM, SHIINA Hideaki <shiina@yndrd.com> wrote:
> I use X2Go server on Ubuntu 14.04.
> I started atom editor on X2Go environment.
> Then, It immediately finished with a message below.
>  "App load time: 147ms"
>
> This problem is known to users and discussed at atom user forum.
> https://discuss.atom.io/t/impossible-launch-on-ubuntu-through-x2go-client/26568
>
> But, There is no solution about it.
> So, I wonder if it's a bug of X2Go.

Have you tried this hack? https://github.com/atom/atom/issues/4360

Uli


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1043; Package atom. (Fri, 01 Jul 2016 02:30:02 GMT) (full text, mbox, link).


Acknowledgement sent to SHIINA Hideaki <shiina@yndrd.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Fri, 01 Jul 2016 02:30:03 GMT) (full text, mbox, link).


Message #15 received at 1043@bugs.x2go.org (full text, mbox, reply):

From: SHIINA Hideaki <shiina@yndrd.com>
To: Ulrich Sibiller <uli42@gmx.de>, 1043@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1043: Atom editor finished immediately after starting.
Date: Fri, 01 Jul 2016 11:18:50 +0900
> Have you tried this hack? https://github.com/atom/atom/issues/4360

Great!

The hack solved my case.

My steps are below.

1. Find `libxcb.so*`. (e.g. find /usr | grep libxcb.so)
2. Find atom installed directory. (dpkg -L atom)
3. Copy libxcb.so* to atom installed directory.
4. Modify libxcb (e.g. sed -i 's/BIG-REQUESTS/_IG-REQUESTS/' libxcb.so.1.1.0)
5. Start atom.


Thank you very much, Uli.




Bug reassigned from package 'atom' to 'nx-libs'. Request was from Mihai Moldovan <ionic@ionic.de> to control@bugs.x2go.org. (Fri, 12 Aug 2016 21:40:01 GMT) (full text, mbox, link).


Marked as found in versions 3.5.0.32. Request was from Mihai Moldovan <ionic@ionic.de> to control@bugs.x2go.org. (Fri, 12 Aug 2016 21:40:02 GMT) (full text, mbox, link).


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1043; Package nx-libs. (Sat, 08 Oct 2016 18:50:01 GMT) (full text, mbox, link).


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri May 24 19:50:02 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.