Subject: Still various unstranslated GUI elements

From: Mike Gabriel <[email-masked]>
Date: Tue, 12 Apr 2016 11:52:56 +0000

Package: x2goclient
Severity: minor
Version: 4.0.5.1

Hi all,

I still see various untranslated string in X2Go Client 4.0.5.1:

   (1) The little down-arrow on session cards:
        "Session preferences..."
        "Create session icon on desktop"

   (2) Main menu: Session -> "Session Management", "Create session  
icon on desktop"

   (3) Session Prefernces dialog window:

       Session Tab

       [x] Try autologin ...

       Input/Output Tab

       (.) Auto-detect keyboard settings

       Sharing

       [x] Use port forwarding...

       About X2Go Client

       -> Description text is in English

   (4) possibly more...

I checked this with LANG=de_DE.UTF-8 and LANG=es_ES.UTF-8. The issues  
occur in both languages, so I presume the causes are in the original  
code somewhere.

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 4 May 2016 05:56:13 +0200

> occur in both languages, so I presume the causes are in the original  

I wasn't able to reproduce any of this, at least on OS X (although some strings
were not displayed there at all, but what I checked was fine.)

Did you see a mixture of translated and untranslated strings, or was everything
untranslated?

Mihai

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 04 May 2016 11:56:59 +0000

Hi Mihai,

> Did you see a mixture of translated and untranslated strings, or was  

The issue was observed on a Linux client running Debian (jessie and stretch).

I saw a mixture of German and English or Spanish and English.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 5 May 2016 21:49:01 +0200

> I saw a mixture of German and English or Spanish and English.

I tried reproducing that issue again on a Jessie VM provided by Stefan. The
stable version of X2Go Client was installed via our repository.

Again, I was unable to reproduce the issue. For both "export LANG=de_DE.UTF-8;
x2goclient" and "export LANG=es_ES.UTF-8; x2goclient" the mentioned messages
showed up in the requested language.

Prior to executing x2goclient, what does locale -a output? Maybe you have a
mixture of locales defined and this is triggering some problem within Qt or
x2goclient.

Mihai