Subject: X2Go issue (in src:x2goclient) has been marked as closed

From: Mihai Moldovan <[email-masked]>
Date: Wed, 6 Apr 2016 17:15:29 +0200 (CEST)

close #1019
thanks

Hello,

we are very hopeful that X2Go issue #1019 reported by you
has been resolved in the new release (4.0.5.1) of the
X2Go source project »src:x2goclient«.

You can view the complete changelog entry of src:x2goclient (4.0.5.1)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goclient.

    http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=911e9b243c21357e49bc477b5323805ff43ef56a;hp=c80b04add271dcdac482c2526708a21b0ec4932c

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goclient.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goclient
Version: 4.0.5.1-0x2go2
Status: RELEASE
Date: Wed, 06 Apr 2016 17:10:10 +0100
Fixes: 1019
Changes: 
 x2goclient (4.0.5.1-0x2go2) RELEASED; urgency=medium
 .
   [ Mihai Moldovan ]
   * Hotfix release for OS X (4.0.5.1):
     - src/onmainwindow.cpp: add (default) MacPorts prefix, /usr/local/bin and
       /opt/X11/bin to x2goclient's environment and child environments before
       starting xmodmap. Fixes: #1019. Requires a re-release of X2Go Client for
       OS X.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Wed, 06 Apr 2016 15:20:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#1019: PATH not correctly set while executing xmodmap

It has been closed by Mihai Moldovan <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mihai Moldovan <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goclient) has been marked as closed
From: Mihai Moldovan <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Wed, 6 Apr 2016 17:15:29 +0200 (CEST)

close #1019
thanks

Hello,

light+love

---

Subject: xcodemap is missing on OS X 10.11
From: Sebastian Fey <[email-masked]>
To: [email-masked]
Date: Tue, 5 Apr 2016 13:45:16 +0200

Package: x2go OS X client
Version: 4.0.5.1

After starting the x2go client, opening a connection and logging in, the 
client reports a missing "xmodmap" binary. The error message is attached 
at the bottom.

The xmodmap binary on my system is located in "/opt/X11/bin/xmodmap". 
The directory path was added to the $PATH variable, but unfortunately 
the client doesn't seem to read the $PATH variable. Due to the new "SIP" 
feature in the new OS X one is not allowed to write to the folders in 
which the client is looking for the binary (even with root privileges).

I'm running OS X 10.11.4 and XQuartz 2.7.8 (xorg-server 1.16.4).

Error message:

"xmodmap failed to start.

This likely means the binary is not available. The current search path 
is: /usr/bin:/bin:/usr/sbin:/sbin X2Go Client will now terminate. File a 
bug report as outlined on the bugs wiki page 
<http://wiki.x2go.org/doku.php/wiki:bugs>."