Well, this kind of problem should not happen nowadays. So I am very interested how this could happen. I ask you to provide some more information:

1. please run setxkbmap -query both outside and inside the (broken) session and report the output.

1b) If the output differs, you can try to run (inside the session) setxkbmap -rules ... -model ... -layout ... -variant ... -option ... 
with the values the _local_ setxkmap -query reports. Does that help?

2. what kind of session are you using? Are you accessing a running X server? Is this happening for all kinds of sessions?

3. What desktop environment are you using locally?

4. What's the keyboard configuration in the x2goclient session configuration?

5. is this happening for new sessions, on reconnect or both?

6. what's the version of nxagent on the server (run 'xprop -root | grep NX' inside the session)?

7. please post the content of /etc/x2go/x2goagent.options

8. on the server you have ~/.x2go/C-something, which is the session dir. You'll find a file called "options" there. Please post that file. You can also scan the session.log for hints what might be going wrong with the keyboard configuration.

9. Has this worked before for you?


On Sun, May 3, 2020 at 2:13 PM stivstivsti . <stiv.yakovenko@gmail.com> wrote:
Package: x2goclient

I am connecting from Ubuntu Linux 18 to another Ubuntu linux machine with x2go. Connection works, but some keys don't, especially arrow keys. When I press up arrow, it starts screen capture:


I tried some recipes from this question: https://serverfault.com/questions/582552/x2go-arrow-key-is-not-working-properly but they don't help. setxkbmap us -print | xkbcomp - $DISPLAY -- doesn't fix the problem. I tried to play with keyboard settings here:


but it doesn't help also. How can I fix it?

I've followed instruction from wiki.x2go.org updating x2goclient to and x2goserver to The problem is still there.
x2go-dev mailing list