Package: nx-libs

Note: This bug might actually be in x2goserver instead.

1. You connect to a KDE4 server
2. You maximize the session
3. #2 This triggers a PolicyKit prompt "Authentication is required to create a color managed device"
4. You select to log out of KDE
5. The screen does not turn black. There is a log out dialog, but it is actually hidden behind the PolicyKit prompt.
6. You are unable to click the log out button in the log out dialog because it is not visible. Hitting escape does not help either. You are unable to move the PolicyKit prompt.

Note: In the absence of the PolicyKit dialog, the screen still does not turn black.

Note: #3. Is a nuisance in and of itself. It is related to the fact that PolicyKit applies different rules for physical logins (active) vs remote logins (inactive.) It is especially a nuisance because you have to click "cancel" repeatedly. However, it is not what I am reporting as a bug.

If you have a local session, this bug does not occur:
3. Trigger a PolicyKit prompt by opening up a terminal and running `pkexec vi` for example.
5. The screen turns black, and the log out dialog appears.
6. You click the log out button and all is well.

This can be worked around by moving the PolicyKit prompt before logging out, or by hitting "cancel" repeatedly.

I am confident this can be worked around also by writing new PolicyKit rules that prevent the "color managed device" prompt. I will post how soon. However, other PolicyKit prompts can presumably still cause this issue.

Server configuration 1: CentOS 7.3 with KDE4 & EPEL's x2goserver & nxagent
Server configuration 2: CentOS 7.3 with KDE4 & nightly x2goserver & nxagent (from the copr repo mikedep333/nx-libs-3.6)
Client 1: Fedora 25 x64 with Fedora's x2goclient & nxproxy
Client 2: Windows 10 1703 x64 with X2Go Client