X2Go Bug report logs - #555
E17 (Enlightenment): Windows cannot be moved by dragging

version graph

Package: nx-libs; Maintainer for nx-libs is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: Michael DePaulo <mikedep333@gmail.com>

Date: Sun, 20 Jul 2014 15:40:01 UTC

Severity: normal

Found in version 3.5.0.27

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#555; Package nx-libs. (Sun, 20 Jul 2014 15:40:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael DePaulo <mikedep333@gmail.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sun, 20 Jul 2014 15:40:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Michael DePaulo <mikedep333@gmail.com>
To: submit@bugs.x2go.org
Subject: E17 (Enlightenment): Windows cannot be moved by dragging
Date: Sun, 20 Jul 2014 11:36:58 -0400
Package: nx-libs
Version: 3.5.0.27
Severity: Normal

Problem:
Under E17 (Enlightenment), when I hold left click on a window title
bar and move the mouse, the window is not moved. I think this is
called "dragging" the window.

In contrast, when I interact with the VM's local display, window
dragging works fine.

Also, in published app mode, window dragging works. (However, the
windows have the Windows OS title bar instead of the E17 title bars.)

Server setup & Steps to reproduce:

Bodhi Linux 2.4.0 64-bit VM with all the latest updates
(Based on Ubuntu 12.04)
Host: Fedora 20 64-bit KVM/virt-manager with the latest updates
"enlightenment" package version: 20130818-1
Enlightenment set to "Bare" desktop. I set this locally, logged out,
and then connected via X2Go.

X2Go Server Installed from from ppa:x2go/stable :
x2goserver 4.0.1.15-0~847~ubuntu12.04.1
x2goserver-xsession 4.0.1.15-0~847~ubuntu12.04.1
nxagent: 2:3.5.0.27-0~446~ubuntu12.04.1

X2Go Client:
Running on Windows 8.1 64-bit with update 1
4.0.3.0 nightly (2014-07-13)
Custom Command: /usr/bin/enlightenment_start
(The same command as in /usr/share/xsessions/enlightenment.desktop)

Things I tried toggling on and off, but had no affect on this bug:
1. In x2goclient, Xinerama extension
2. in x2goagent.options, XFIXES extension
3. In x2goagent.options, GLX extension


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sat Dec 27 10:52:04 2014; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.