Subject: Bug#16: Fixed in release nx-libs 3.5.0.15

From: Mike Gabriel <[email-masked]>
Date: Fri, 21 Sep 2012 10:17:20 +0200

tags #16 fixed
close #16
thanks

Fixed in release nx-libs 3.5.0.15.

nx-libs (2:3.5.0.15-0) unstable; urgency=low

   [ Mike Gabriel ]
   * Improve 020_add-nxagent-wrapper.full.patch: Properly set NX_TEMP, make
     sure nxagent launches even with pam_tmpdir.so being in use.
   * Improve 023_add-x2goagent-wrapper.full.patch: Properly set NX_TEMP, make
     sure x2goagent launches even with pam_tmpdir.so being in use.
   * Add VERSION.x2goagent to package x2goagent package so x2goversion command
     lists up x2goagent in the list of X2Go server-side packages.
   * Refresh patch: 200_nxagent_check-binary-x2go-flavour.full.patch.
   * Make sure the NX_TEMP envvar gets set in all wrapper script for all nx*
     execubles.
   * Link libNX_Xrandr to a separate location where we can provide it as
     libXrandr.
   * /debian/control:
     + Maintainer change in package: X2Go Developers  
<[email-masked]>.
     + Priority: optional.
   * Add patch: 220_nxproxy-bind-loopback-only.full+lite.patch, adds loopback
     option to nxproxy options and forces nxproxy to bind to loopback devices
     only.

   [ Oleksandr Shneyder ]
   * Add patch: 204-nxagent_repaint-solidpict.full.patch. Fixes repainting of
     SolidFill pictures by nxagent/x2goagent on reconnects. Closes upstream
     issue #16.

  -- Mike Gabriel <[email-masked]>
     Fri, 21 Sep 2012 10:02:16 +0200

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fr, 21 Sep 2012 08:17:53 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goagent package:

#16: Fwd: [X2Go-Dev] Broken glyphs and icons after suspending a session

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Fixed in release nx-libs 3.5.0.15
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Date: Fri, 21 Sep 2012 10:17:20 +0200

tags #16 fixed
close #16
thanks

   [ Mike Gabriel ]

   [ Oleksandr Shneyder ]

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: Fwd: [X2Go-Dev] Broken glyphs and icons after suspending a session
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Date: Mon, 10 Sep 2012 13:50:09 +0200

Package: x2goagent
Severity: important
Version: 3.5.0.14

Hi all,

putting this mail from x2go-dev mailing list into our new BTS to  
follow the progress on this issue.

Mike

----- Weitergeleitete Nachricht von [email-masked] -----
      Datum: Sat, 12 May 2012 00:10:11 +0200
        Von: Holger Hahn <[email-masked]>
Antwort an: [email-masked]
    Betreff: [X2Go-Dev] Broken glyphs and icons after suspending a session
         An: [email-masked]

Hello x2go dev team,

as I was looking for an alternative on NX nomachine, because it was
broken with the last Cairo 1.12 update, I found your x2go solution,
which is great.

So as it bases on the same libraries than the original nomachine, you
had the same issues - with rendering to undrawable objects, the whole
nxagent crashes because of SEGV.

With the patch of Jan (thanks to) you committed to the master branch
today, I compiled another nxagent. Actually it worked fine, but after
suspending and reconnecting to a session, some graphical objects get
broken...

All characters/fonts that has been rendered on the screen prior the
suspension, are gone. (See Screenshots the link below).
Creating new text by starting applications is ok, as long as the
characters has not been rendered in the session before.

I thought it might be problem with a kind of glyph cache of the X
session (ubuntu/x86 x2goclient). But I found one case, where
additionally to the text, all icons are gone also, which was with an
debian/x64 x2goclient... (Difference can be seen on screenshots)

Might it have to do something with the patch from today, that could
filter out to much rendering? Or is this issue known from somewhere else?

Here are some screenshots: http://www.computerfreak.de/sonic/x2shots/

Thanks for your help,
Holger
_______________________________________________
X2Go-Dev mailing list
[email-masked]
https://lists.berlios.de/mailman/listinfo/x2go-dev

----- Ende der weitergeleiteten Nachricht -----

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: